Mappage lecteur réseau...

Installation, configuration, utilisation et dépannage du réseau sous Windows.

Mappage lecteur réseau...

Messagepar Badge » Ven 29 Mai 2020 14:05

Bonjour,

Suite à la mise à jour 2004 de mon Windows 10 pro, mes mappages de lecteurs réseau ne fonctionnent plus... enfin presque plus.

Après chaque redémarrage, je suis obligé de les supprimer puis de les recréer et là, ça marche.

Si quelqu'un à une idée ou une piste à creuser, je suis preneur.

Par avance, merci.
Image
Avatar de l’utilisateur
Badge
 
Messages: 18
Inscription: Dim 18 Mai 2014 06:15

Re: Mappage lecteur réseau...

Messagepar jjcojax » Lun 1 Juin 2020 08:23

Bonjour,

En fait, tu as raison, probablement que Win10 devient vieux (Alzheimer)

Je ne sais pas comment tu fais tes "mapages", mais pour Windows, j’utilisais "net use"

Ce qui fonctionne sous Win7 ne fonctionne pas sous Win10 (je ne sais pas pourquoi) :oops:

Dans mon exemple, je donne la lettre R; à un dossier qui se trouve sur un autre PC (Windows ou Linux, c'est pareil)

Si je le fais en Win10 la commande indique OK
Image

Je redémarre, et c'est perdu :bizar:
Image

Si je fais pareil sous Win7
Image

Je redémarre et c'est toujours OK
Image

----
Comme tu es sous Win10, et que tu as probablement une autre méthode que moi pour tes "mappages", indique ta méthode pour que moi, ou un autre te trouve une solution.

jjcojax
Avatar de l’utilisateur
jjcojax
 
Messages: 227
Inscription: Dim 4 Déc 2016 10:36

Re: Mappage lecteur réseau...

Messagepar mwonex » Lun 1 Juin 2020 15:40

Bonjour,

Pas grand chose de neuf, mais vérifie quand même les services (si en manuel):
Dans la liste, vérifiez que les services suivants ne sont pas désactivés :

Hôte de périphérique UPnP (upnphost)
Découverte SSDP (SSDPSRV)
Hôte du fournisseur de découverte de fonctions (fdPHost)
Mappage de découverte de topologie de la couche de liaison (lltdsvc)
Publication des ressources de découverte de fonctions (FDResPub)

https://www.malekal.com/decouverte-reseau-fonctionne-pas-windows-10/

tu peux aussi supprimer les précédentes liaisons, voir avec la commande net use pour la refaire:
Code: Tout sélectionner
net use * /delete

perso ma liste est vide:
Microsoft Windows [version 10.0.19041.264]
(c) 2019 Microsoft Corporation. Tous droits réservés.

C:\Users\user>net use * /delete
La liste est vide.


et plein d'autres
https://www.malekal.com/net-use-windows-partage-lecteur-reseau/

Pour le moment, je ne vois rien de plus, sauf que je n'ai pas mon réseau étant absent de la maison :mrgreen:

Aaaaah cette mouche, je souffle pour rien je vais chercher ma bombe;)
Image
@+
Version 2004 (version 19041.423) « Mieulx est de ris que de larmes escrire, Pour ce que rire est le propre de l'homme. » F. Rabelais. .« Nous ne sommes pas ce que nous savons mais ce que nous sommes prêts à apprendre » M.C. Bateson
Avatar de l’utilisateur
mwonex
 
Messages: 3983
Inscription: Dim 7 Juin 2015 13:46

Re: Mappage lecteur réseau...

Messagepar Badge » Mer 3 Juin 2020 07:47

Bonjour tout le monde,

Avant tout, merci pour vos interventions.

Que je passe par l'explorateur de fichier, "Connecter un lecteur réseau" ou en ligne de commande avec "net use" le résultat est toujours le même...

Lorsque je redémarre mon PC, le lecteur mappé précédemment apparaît ainsi :

Image

et si je clic dessus ça me donne ça :

Image

Par contre, si je déconnecte puis recrée mon mappage, je peux l'utiliser sans problèmes... jusqu'au redémarrage suivant :bizar:

Encore merci et à bientôt...
Image
Avatar de l’utilisateur
Badge
 
Messages: 18
Inscription: Dim 18 Mai 2014 06:15

Re: Mappage lecteur réseau...

Messagepar mwonex » Mer 3 Juin 2020 13:16

Version 2004 (version 19041.423) « Mieulx est de ris que de larmes escrire, Pour ce que rire est le propre de l'homme. » F. Rabelais. .« Nous ne sommes pas ce que nous savons mais ce que nous sommes prêts à apprendre » M.C. Bateson
Avatar de l’utilisateur
mwonex
 
Messages: 3983
Inscription: Dim 7 Juin 2015 13:46

Re: Mappage lecteur réseau...

Messagepar Badge » Lun 8 Juin 2020 09:52

Merci pour vos interventions... malheureusement infructueuse :oops:

Si je me réfère à ce post, Il semblerait que ce n'est pas la première fois que ce genre de gag se produit. :bizar:

Peut être qu'avec un peu de patience :hein:

Encore merci.
Image
Avatar de l’utilisateur
Badge
 
Messages: 18
Inscription: Dim 18 Mai 2014 06:15

Re: Mappage lecteur réseau...

Messagepar jjcojax » Lun 8 Juin 2020 13:42

Re,

En fait, j'avais ce problème sur plusieurs machine avec la version 1909, et le problème a disparu après la mise à jour 2004.

Toi, c'est le contraire :hein:

C'est peut être que tu as une autre manière pour tes créer tes mappages qui contournais le défaut (voir ton lien Microsoft)

Tu as montré ceci :

Image

Que donne "net use" juste après un restart (affiche les connexions réseau)

Si X: est déjà dedans, vois quel est la cible, et pour enlever un mappage, par ex: "X:" ,tu peux le supprimer via "net use X: /d"

2ème point à voir...

Via regedit, tu peux voir si la lettre de lecteur (X:) n'est pas déjà attribuée à un autre disque ou partition ou dossier (ça peut être une clé USB que tu as mis jadis et qui sera à nouveau X: si tu la remets)

Je te montre ou tu dois aller, toi, tu auras probablement un lecteur X: dans ta vue

Image

Pour les lettres de lecteurs qui ne doivent pas restés coincées dans le registre, tu peux enlever toutes les clés genres \DosDevices\T:

Ne crains rien, même si tu enlèves tout, chaque partitions que l'explorateur de Windows peux lire recevra une lettre de lecteur
(mais peut être une autre ce qui n'est pas un problème puisque le gestionnaire de disque te permet de choisir une autre lettre de lecteur) (sauf pour C: qui doit resté C:)

Suite si ...

jjcojax
Avatar de l’utilisateur
jjcojax
 
Messages: 227
Inscription: Dim 4 Déc 2016 10:36

Re: Mappage lecteur réseau...

Messagepar Badge » Ven 12 Juin 2020 11:26

De nouveau moi...

Donc pour résumé, ceci se produit depuis la mise à jour en 2004 car avant, ça fonctionnait nickel.

Que ce soit via l'explorateur ou via Net Use et même en faisant le ménage comme conseillé plus haut, même combat :oops: Je peux créer les mappages, ils fonctionnent mais si je redémarre le PC, les reconnexions sont en échec. Je suis obliger de les supprimer puis de les recréer.

En fait, j'ai différents Mappages sur différents types de serveurs (Windows et autres) et le problème est le même.

Sur le serveur Windows SMB 2 n'était pas actif donc la connexion se fesait via SMB 1... Après avoir activé SMB 2 sur ce serveur... miracle, la reconnexion fonctionne.

Sur l'autre machine, (un e-series d'IBM), il a fallut appliquer quelques mises à jour afin d'activer SMB 2 et depuis... ben ça fonctionne aussi.

Ma conclusion : La mise à jour 2004 apporte une modification au niveau de SMB 1 qui pose problème.

Je n'ai donc pas résolut le problème mais je l'ai juste esquivé... :bizar:

D'un autre coté, depuis le temps que je voulais tout passer en SMB 2, (parce que SMB 1 c'est pas très prudent) ben maintenant, c'est fait. :D

Encore merci pour vos interventions.
Image
Avatar de l’utilisateur
Badge
 
Messages: 18
Inscription: Dim 18 Mai 2014 06:15

Re: Mappage lecteur réseau...

Messagepar mwonex » Ven 12 Juin 2020 13:09

Bonjour,

SMBv1 n’est pas installé par défaut dans Windows 10 version 1709, Windows Server version 1709 et versions ultérieures

https://docs.microsoft.com/fr-fr/windows-server/storage/file-server/troubleshoot/smbv1-not-installed-by-default-in-windows

Je ne vois pas pourquoi il le serait sous Windows 10 2004?

Il est connu pour faciliter l'entrée de virus, en tous ça remplacé par smb2.

identifier l'état smb2:
Windows PowerShell
Copyright (C) Microsoft Corporation. Tous droits réservés.

Testez le nouveau système multiplateforme PowerShell https://aka.ms/pscore6
PS C:\Users\miche> Get-SmbServerConfiguration | Select EnableSMB2Protocol

EnableSMB2Protocol
------------------
True

Ici les méthodes d'activation du smb2:
https://docs.microsoft.com/fr-fr/windows-server/storage/file-server/troubleshoot/detect-enable-and-disable-smbv1-v2-v3
Mon Smb1:

Capture-SMB1 désactivé.PNG
Capture-SMB1 désactivé.PNG (26.03 Kio) Vu 110 fois

Voir aussi des explications sur les partages quand les protocoles sont différents:
https://www.malekal.com/activer-desactiver-smb-windows/

Reste la possibilité de revenir à la version 1909 :hein:
@+
Version 2004 (version 19041.423) « Mieulx est de ris que de larmes escrire, Pour ce que rire est le propre de l'homme. » F. Rabelais. .« Nous ne sommes pas ce que nous savons mais ce que nous sommes prêts à apprendre » M.C. Bateson
Avatar de l’utilisateur
mwonex
 
Messages: 3983
Inscription: Dim 7 Juin 2015 13:46

Re: Mappage lecteur réseau...

Messagepar Badge » Ven 12 Juin 2020 13:18

Et ouaip... j'avais vu tout ça 8-)

Mais en fait, une fois que tous mes serveurs auront SMB 2 actif, ben je vais surtout désactiver SMB 1 :D
Image
Avatar de l’utilisateur
Badge
 
Messages: 18
Inscription: Dim 18 Mai 2014 06:15

Suivante

Retourner vers Réseau / internet

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité